spacer.gif, 0 kB
URD logo   August 24, 2017, 06:47:52

 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length


Pages: [1]
  Print  
Author Topic: LinuxMint 18 Install Guide needed?  (Read 1825 times)
Lucap

Posts: 16


View Profile
« on: October 01, 2016, 12:14:27 »

Can anyone write up a step by step Mint 18 install guide?

Way too many Deb,Script and Dependencie errors for a newbie like me.
Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #1 on: October 01, 2016, 14:53:20 »

Mint is essentially the same as ubuntu. So I suppose the steps used for ubuntu should work in mint as well.

So this should still work:
http://urdland.com/wordpress/download/

Essentially:
Code:
# sudo apt-get update
# sudo apt-get upgrade
# sudo apt-get install apache2 php5 mysql-server procps
# sudo apt-get install php5-cli php5-mysql php5-xmlrpc php5-curl php5-gmp php5-mcrypt
# sudo apt-get install yydecode unrar par2 trickle smarty coreutils
# sudo dpkg -i urd_1.13.0-1_all.deb

If you run into any trouble let me know
Logged
Lucap

Posts: 16


View Profile
« Reply #2 on: October 01, 2016, 15:35:53 »

That's what i followed but it's just one error after another, perl 5 was no good then perl 7 spat out errors and even smarty wasn't found and suggested smarty3 and urd_1.13.0-1_all.deb gave script errors.

/etc/apt/sources.list - permission error and yydecode from archive.getdeb didn't exist.

To complex for a newbie like me , need a new guide or Flatpak. Smiley
Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #3 on: October 01, 2016, 18:26:45 »

I updated the instructions a bit.

You don't need to install smarty.

if yydecode is not in any repo, you probably need to compile it from source. Alternatively there is a yydecode.php in the tools directory, that you can use but performance may be in issue (but maybe better with php 7 than before)

You don't need perl

Please be sure to post exact errors not just descriptions
Logged
Lucap

Posts: 16


View Profile
« Reply #4 on: October 02, 2016, 10:20:49 »

Reason i was vague about the errors and mistakenly said Perl Instead of PHP was because i was trying this on the Mint 18 live boot and had closed down before i posted and forgot that i wouldn't have any logs.

When i get a chance i'll try again with the updated instructions and i'll keep the session open so i can post any errors if i should get any.

Thanks
Logged
Lucap

Posts: 16


View Profile
« Reply #5 on: October 04, 2016, 11:39:16 »

Installed PHP-7 , i had to compile and install yydecode myself but then <dpkg -i urd_1.13.0-1_all.deb>
refused to unpack and install as it gave errors that it depended on PHP-5.

Best if someone with better Linux skills boots a Mint 18 live disk to find out what needs to be done so us Mint 18 users can use URD as it's beyond a windows to Linux noob like me as i could be part of the problem with my lack of linux knowledge.


Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #6 on: October 04, 2016, 19:49:14 »

Ah yeah I see the issue. This is ubuntu generic.

If you have satisfied all the other dependences installed the php v7 packages as described on the install doc, I presume it is save to use

Code:
dpkg -i --force-depends  urd_1.13.0-1_all.deb

When a next version is released I'll look into the packaging.

Logged
Lucap

Posts: 16


View Profile
« Reply #7 on: October 08, 2016, 10:28:22 »

<dpkg -i --force-depends  urd_1.13.0-1_all.deb>

(Reading database ... 233938 files and directories currently installed.)
Preparing to unpack urd_1.13.0-1_all.deb ...
Unpacking urd (1.13.0-1) over (1.13.0-1) ...
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive urd_1.13.0-1_all.deb (--install):
 subprocess new post-removal script returned error exit status 1
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 urd_1.13.0-1_all.deb
Logged
Lucap

Posts: 16


View Profile
« Reply #8 on: October 08, 2016, 10:31:18 »

Not sure what Status 1 errors are but i had status 1 errors the first time i tried to install URD before this force command.
Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #9 on: October 08, 2016, 11:02:38 »

I don't know either what the status code 1 is.

But you seem to be updating an existing package - I presume half installed. Probably should remove the package first.

Otherwise just take the source package instead. Basically the .deb is only extracting the files to a directory and updating apache to include the directory
Logged
Lucap

Posts: 16


View Profile
« Reply #10 on: October 08, 2016, 11:28:47 »

Sigh!  , Something seems corrupt.

<apt-get remove URD>

Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: The package urd needs to be reinstalled, but I can't find an archive for it.

<apt-get purge URD>

Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: The package urd needs to be reinstalled, but I can't find an archive for it.

<apt-get install URD>

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package urd needs to be reinstalled, but I can't find an archive for it.
« Last Edit: October 08, 2016, 11:32:06 by Lucap » Logged
Lucap

Posts: 16


View Profile
« Reply #11 on: October 08, 2016, 11:49:21 »

tar -zxf urd-1.13.0.tar.gz

cd urd-1.13.0

LS

docs      functions  index.php  LICENSE         make_x_lang.php  README.md  urdd     urdd_syslog.conf
examples  html       install    mail_templates  README           urd.conf   urdd.sh


./configure
bash: ./configure: No such file or directory

cp -rf urd-1.13.0 urd
cp: cannot stat 'urd-1.13.0': No such file or directory

Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #12 on: October 11, 2016, 17:25:19 »

you don't need to run configure. Basically copy/unzip it to any directory. Make sure apache can read it (example config urd.cnf for apache should be in root directory) restart apache and point your browser to the location you configured in the apache conf e.g. http://localhost/urd/ in the example config. Then just follow the installer.
Logged
spearhead
Administrator
*
Posts: 1184


View Profile WWW
« Reply #13 on: October 11, 2016, 17:27:00 »

that said. you better run the latest git version from https://github.com/gavinspearhead/urd if you use php7 there are some changes in php7  that aren't working very smoothly with urd 1.13.
Logged
Lucap

Posts: 16


View Profile
« Reply #14 on: October 12, 2016, 06:49:45 »

After 2 weeks of errors and not getting anywhere it would be quicker and easier if i just installed Kodi with a TV & Movie add-on , or alternatively run Wine in Firejail and use Newsbin Pro.
Logged
Lucap

Posts: 16


View Profile
« Reply #15 on: November 05, 2016, 15:07:49 »

http://www.ihaveapc.com/2011/10/fix-annoying-the-package-needs-to-be-reinstalled-but-i-cant-find-an-archive-for-it-error-in-linux-mint-ubuntu/

Oct 13th, 2011

Quote
Search for the package name that appears in the error. Note that, in our case the culprit package was ‘urd’ which was in ‘purge reinstreq half-installed’ state. After you have located the culprit package, delete the section of information related to that package and save the file. In our case, we deleted the section related to ‘urd’ inside the rectangle and saved the file. Close ‘gedit’ when done

It turns out your program has been fucking up Mint/Ubuntu and corrupting the packages for years , i had to follow the above guide to remove it and get my package manger back.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
Amigri by Fakdordes
spacer.gif, 0 kB
spacer.gif, 0 kB
spacer.gif, 0 kB